Setting up the AVR Jungo USB Driver manually

Now it’s around 2 AM in the morning, ouch its 2 AM midnight actually. Though there are a lot of beautiful that can happen for a typical Friday night, but am in middle of a STK 600, a Dell Latitude with Windows 7 X64 and a broken connection between these two. So I started to dig this out and see if I can fix things myself and I am pretty much pleased that I was able to make it work. So here is the story of it.

The Problem

My STK 600 was not detected either by Studio 5.0 or Studio 4 or even by stk600.exe. Some symptoms are as follows.

Shows up in Device Manager : YES, but with a yellow warning icon.

Gets enumerated as USB device : Yes it does, I am able to see it in the programming dialog of studio 5.

Tools Firmware Upgrade in Studio 5 : Didn’t find it though.

In Studio 5 programming dialog, am able to see it’s id and if I select the interface as “JTAG” and click “Apply” it throws error “Unable to connect to tool”. So as far as know, I interpreted the symptoms to be a problem with the Jungo USB driver. I installed/uninstalled the Jungo driver many times, but hardly able to notice whether it succeeded or failed. But am pretty sure that the Jungo USB driver just launches the wdreg.exe tool to install the drivers internally. So to make it work I followed these steps.

Extract the Jungo Installer from Studio. To do this take the studio  installer. Then from command prompt type the following command

       installername.exe /extract_all:c:\foo

You can alternatively use your own path rather than c:\foo. Now the command prompt will return immediately but wait for some time for the extraction to complete and then, goto c:\foo\disk1\ISSetupPrerequisites\{someguid}\AVRJUngoUSB.exe. This is the installer we want to make things work.

Now run the installer. It will run as normal. Then after completion go to the install location of Jungo. This would by default be c:\Program files (x86)\Atmel\AVR Jungo USB. Now check if things work, in some case you might be lucky Winking smile

Now inside that folder there will be two folders usb32 and usb64, since we are here for a Win 7 x64 cause we should use the usb64 folder.

Now launch a command prompt with elevated privileges (Right click cmd.exe –> Run as Administrator).

From the command prompt go to the usb64 folder

Type the following.

wdreg.exe –inf windrvr6.inf uninstall

Now some logs will appear and it should say succeeded. After that go to the folder c:\windows\inf and see if any of your stk600.inf file persists. If so delete them. Then goto C:\Windows\System32\DriverStore\FileRepository\ and look for windrvr6.sys kind of folder and delete it (if it exists). Now reboot the system.

Then goto the usb64 folder from command prompt as administrator. Run the command.

wdreg.exe –inf windrvr6.inf install

This made things work for me atleast. Hope you might find this useful

.csharpcode, .csharpcode pre
{
font-size: small;
color: black;
font-family: consolas, “Courier New”, courier, monospace;
background-color: #ffffff;
/*white-space: pre;*/
}
.csharpcode pre { margin: 0em; }
.csharpcode .rem { color: #008000; }
.csharpcode .kwrd { color: #0000ff; }
.csharpcode .str { color: #006080; }
.csharpcode .op { color: #0000c0; }
.csharpcode .preproc { color: #cc6633; }
.csharpcode .asp { background-color: #ffff00; }
.csharpcode .html { color: #800000; }
.csharpcode .attr { color: #ff0000; }
.csharpcode .alt
{
background-color: #f4f4f4;
width: 100%;
margin: 0em;
}
.csharpcode .lnum { color: #606060; }

About these ads