Atmel studio installation problem: The extension is not installable……

When installing Atmel studio 6.0, users might very rarely see a error dialog as follows

If you are one such person who sees this, then it’s better to close the installer than running it. This means that some parts of studio are not installed properly due to probably unavailable of system resources in many cases. To work around the problem, close all programs, restart the PC and then start the installation a fresh. Don’t run heavy weight applications in the background. Then you should be ok.

Technically a bit more detail : Atmel studio is a composed application, means that it is composed of several entities like frontend IDE, backend debugger, Toolchain system, assembler, toolchain , ASF. Though each of these is separate extensions, still one is dependent on the other. When we say installing Atmel studio it actually means installing Prerequisites, Atmel studio runtime, backend, then extensions and finally preparing some help content and stuff. So to install extensions we need to copy a portion of Atmel studio that I refer to as runtime and then preparing some registry. This step is called Atmel studio intial runtime setup, which could be seen in installer as “Initializing Atmel studio for first time run”, and the maximum time allotted for this activity is 5 minutes and if this action times out then the atmel studio runtime initialization fails and the subsequent installations of extension would obviously fail. In the next version we have fixed the issue and this should not be seen in the future releases of Atmel studio. Thanks to my collegue Parthasarathy, who found out this issue.

Have a good time with Atmel studio and it’s future.

J

Advertisements