Atmel Studio 7 FAQ

The following are some of the frequently asked questions about Atmel Studio 7.0 (build 582). The list of items will change over time as Atmel studio 7.0 gets more updates. This FAQ doesn’t apply to any of the previous versions of Atmel Studio 6.0.

  1. My installation fails where will I get the log files for installation?
    Ideally the last page in the installer should have a hyper link to the log folder, usually it is %temp%\Atmel Studio <Build Number> (i.e) %temp%\Atmel Studio 7.0.582
  2. Where are Atmel Studio “IDE logs” located ?
    %AppData%\Roaming\Microsoft\AppEnv\14.0\ActivityLog.xml
  3. I found the log folder where can I start looking to find information to trouble shoot log the installation?
    The installer master log file will be available at %temp%\Atmel Studio <Build Number> \AS_*.log (i.e) %temp%\Atmel Studio 7.0.582\AS_20151008143038.log.
  4. How to enable detailed logging for programming and debugging
    Refer here
  5. I find that one of the component has failed during installation, is there a specific log for the component installation?
    Yes, if a specific component has failed you will find that component log and its path in the parent log file.
  6. Windows is not up-to date will the isolated shell installation fail?
    Yes, Isolated shell installation will fail if KB2919355 is not available for Windows 8.1 and Windows Server 2012
  7. My Isolated shell failed with the error what can I do to get more information on the failure?
    Invoke as-installer-7.0.582-web.exe SHELLCOMMAND=/NoWeb /NoRefresh /NoRestart
    This will start Isolated shell installer GUI apart from the Atmel Studio 7.0 installer GUI. So the user should be able to see the progress of the Shell installation and any errors captured from the GUI level.
  8. How to check the Windows update installed in the machine ?
    http://windows.microsoft.com/en-us/windows/which-windows-updates-installed
  9. How to troubleshoot he Windows update mechanism?
    http://windows.microsoft.com/en-us/windows/troubleshoot-problems-installing-updates
  10. I see a blank installer screen with Atmel Studio 7.0 in the title bar?
    It could be the registry entries of the installer got corrupted in order to fix it. Do the following:
    Run Fix it ttps://support.microsoft.com/en-us/mats/program_install_and_uninstall
    Select Detect problems and let me select the fixes to apply
    Select Installing for the question Are you having a problem with installing or uninstalling?
    Fix the products like Microsoft Visual Studio 2015 Shell (Isolated)
  11. Visual Assist Options are greyed out what should be done?
    Update the graphics driver to fix it.
  12. I get a license expired error from Isolated shell when I start Studio?
    Repair the component Microsoft Visual Studio 2015 Shell (Isolated) from Control panel -> Programs -> Programs and Features
  13. When I start Studio, I see that the toolbars are greyed out?
    Restart studio it should fix the issue.
  14. When importing an Arduino sketch i get an error “Sequence contains no elements”
    test
    This would possibly come, when you have a older version of Arduino installed (< 1.5.6 r2). To fix this,
    Please delete the %appdata%\Arduino15\preferences.txt , and restart the IDE. (Note : The name of the folder can be Arduino instead of Arduino15. If both Arduino and Arduino* are present, delete them all.
  15. Supported Arduino IDE’s for “Sketch Import”
    arduino-1.5.6-r2
    arduino-1.5.8
    arduino-1.6.0
    arduino-1.6.1
    arduino-1.6.4
    arduino-1.6.5-r2
    arduino-1.7.3
    arduino-1.7.4
    arduino-1.7.5
    arduino-1.7.6

  16. My board doesn’t show up in the “Sketch Import Wizard”
    Importing sketches are supported only for the boards comes with the default Arduino installation, means the boards that are listed in the boards.txt file in <ArduinoInstallation>\hardware\arduino\avr\boards.txt. Boards that are installed via board manager will be supported only in future. (Note : Arduino Due board is available with the default installation till arduino 1.6.2, but in later versions it is removed and only available through boards manager)
  17. Error while importing an sketch for “Arduino Due” board and device cortex-m3
    ARM-not-supported
    “The project contains a device cortex-m3 which is not supported by Atmel Studio. Please select another device”.
    Support for importing ARM based Arduino sketches are not available yet, and should be available in future versions. The only affected board that looses the opportunity to be imported is the Arduino Due. Apart from this all the other boards listed here should be supported. https://en.wikipedia.org/wiki/List_of_Arduino_boards_and_compatible_systems
  18. Imported Arduino project doesn’t compile. (I am using an Operating system with language other than English-US or English-UK).To fix the issue,
    1. Open Arduino IDE (Close Atmel Studio 7)
    2. File -> Preferences -> “Editor Language” -> English
    3. Close Arduino IDE.
    4. Now open Atmel studio 7.0.
    5. Import the project.
    6. It should work.
  19. Sketches with user defined header files doesn’t build after importing into Atmel Studio. (e.x toneKeyboard, toneMelody, toneMultiple fails with error pitches.h: No such file or directory).
    This is a bug with Atmel Studio 7.0 and will be fixed in later version. To fix the error, you need to copy that file(s) to the include directory in project. To do that follow these steps

    1. Click View menu, Select “Solution explorer”.
    2. In Solution Explorer, Right click the “include” folder in project.
    3. Select Add -> “Add Existing”. A file selection dialog will appear.
    4. From the dialog select the header file(s) and click OK. (Hint : Usually the files are in the same folder as the sketch)
    5. Now build the project, and it should succeed.
  20. The Visual Studio Component cache is out of date. Please restart Visual Studio.
    component_cache_out_of_date
    When you see this error, close all instances of Atmel Studio and restart it. This should fix it in almost all cases. But if this didn’t work, then goto the folder %localappdata%\Atmel\AtmelStudio\7.0, and delete the folder “ComponentModelCache”, then restart Atmel Studio.
  21. During Project build i see error messages like this. Can we ignore them ?
    Target “PreBuildEvent” skipped, due to false condition; (‘$(PreBuildEvent)’!=”) was evaluated as (”!=”)
    Target “PostBuildEvent” skipped, due to false condition; (‘$(PostBuildEvent)’ != ”) was evaluated as (” != ”).
    prebuild-postbuild-atmelstudio-skippedYES, you can ignore them. This basically means that the build system figured out that you don’t have any prebuild or post build step and it diligently reports the evaluation condition to run them failed and so it will skip. This should neither be treated as warning. It’s just an informational message in the build step.
  22. When launching help I get the following error.
    “The help viewer command line includes an invalid catalog name AtmelStudio70. Specify a valid name”
    help-viewer-error-atmel-studioThis is a known issue with a subset of Windows machines in Atmel Studio 7.0.582. To fix this please install the build Atmel Studio 7.0.594 from here.
  23. When installing Intel Graphics driver i get the following error / dialog boxes, what does it mean ?
    “This computer does not minimum requirement for installing the software”.
    incompatible-video-driver* GFX HW not found; disabling HDMI driver install
    Removed INF = Video_Driver_MW8G3_WN32_10.18.14.4170_A16\DisplayAudio\IntcDAud.inf
    ! Didn’t find any INF’s that match active hardware
    IIF will NOT initiate reboot
    Exit code = 0xA005
    ResultCode = 40965
    And Then
    incompatible-video-driver-1This means that you have attempted to choose / install the wrong display driver.  When downloading the display driver make sure you have chosen the right driver for your operating system and PC manufacturer.
  24. No Simulator for imported Arduino project when using Leonardo board.
    Atmel studio 7.0 doesn’t support simulating the Atmega32U4 device, and have no plans to support it anytime soon.
  25. Hex file size is bigger when importing a sketch in Atmel Studio and building it.
    https://avrstudio5.wordpress.com/2015/10/19/imported-arduino-sketch-is-bigger-in-size-than-what-it-is-in-arduino/
  26. Error when compiling sketch with GSM library. “expected unqualified-id before numeric constant,  in expansion of macro DEBUG”.
    This is possibly because Atmel Studio 7, defines DEBUG macro by default and that conflicts with some symbols in the GSM library. To fix it please remove the DEBUG macro from Atmel Studio -> Project properties -> GNU/AVR C Compiler -> Preprocessor -> DEBUG -> Delete (x). To fix it please remove the DEBUG macro from Atmel Studio -> Project properties -> GNU/AVR C++ Compiler -> Preprocessor -> DEBUG -> Delete (x)
Advertisements